Save Data


Click here to see a quick tutorial video on exporting your data products!

SlantView provides a number of options and formats for exporting data, shown in the Table below. Namely, the map layers, individual images or the entire set of images, which can be exported as KMZs, Shapefiles, and/or GeoTIFFs.

  • With your mouse over the map right-click and select Export – Maps
  • Select to export either the current view or All views
  • Select the file type for the exported map

Data export options

Map Views KMZ GeoTIFF SHP
Map (current layer) X X
Map (all layers) X X X
Individual Image (current layer) X X
Individual Image (all layers) X X
All Images X

Figure 1: Map Window right-click menu

Exporting the current view will save only the map layer that is currently displayed in SlantView. For example in Figure 1, the current view is the Stress layer, therefore selecting to export the current view will only save the Stress layer. Alternatively, saving all layers will save every map layer currently available in the Map Window, as chosen from the settings menu: NDVIs, Stress, Vegetation fraction, and/or Yield potential.

The options for saving the data are KMZ (to view in Google Earth), Shapefile (for use with various Ag software packages), or multipage GeoTIFF (standard image format similar to an uncompressed jpeg). The exported file is saved within the folder that was initially selected to load the data.

In addition to saving maps, the user may also save an individual image as KMZ or GeoTIFF by clicking Export—Image to export the image currently in the Image Window. The right click options from the Map window only allow exporting all layers of an individual image, however a single layer KMZ image can be exported by making the image window active right-clicking and selecting Save image as KMZ – Current view.

Note

If the Store locally box was checked upon initial Processing, SlantView will save the exported files in C:\SlantRange\Data\[Grower]\[Field name] alongside all other files in the Dataset, otherwise the files will be saved in the folder that was selected to load the Dataset. If you are not sure where the files are being saved, the Image Window Title Bar displays the path to the active directory.


Export Processed Images

This performs the same function as selecting Export images in the Processing menu.

View maps with Google Earth, and view map statistics

From the Map Window, the user can save a KMZ archive and open the map products in Google Earth directly, as shown in Figure 2. The user can also view statistics in HTML format:

  • Right click—View maps with Google Earth.

  • Right click—View map statistics.

Figure 2: View maps with Google Earth, and view map statistics

Statistics for each of the map products available in the Map Window, as selected in the Processing settings menu (NDVIs, Stress, Vegetation fraction, Yield potential, and any active Custom Filter maps), will be displayed in your default web browser, as shown in Figure 3.

Figure 3: HTML map statistics


Saving a Workspace

A Workspace can be saved in a variety of simple steps. The easiest of which is to select OK when prompted to save the Workspace upon opening a new Dataset or closing an active SlantView Map Window. Additionally, you can save the Workspace at any time by clicking: Data—Save—Workspace, as shown in Figure 4.

Saving the Workspace preserves the most recent settings used to Process the data, as well as any Custom boundaries. Loading a Workspace allows the user to return to a map in a given desired state, instead of Reprocessing from scratch and reapplying settings. Also, a Workspace will open in a fraction of the time of Reprocessing an entire Dataset!

Figure 4: Saving a Workspace

Note

Workspaces are roughly the same size as the Dataset used to create them, therefore storing many Workspaces may take up signficant hard drive space. The Workspace file will be saved within the folder that was previously selected to load the Dataset. For Datasets loaded with the Store Locally or Download boxes checked, the Workspace will be at C:\SlantRange\Data\[Grower]\[Field name] alongside all other files in the Dataset.

Saved Data Settings


To adjust the settings of your saved data, open the Export Options menu from either the Data or Settings tabs in the main Map Window Menu, as shown in the Figure below:

Figure 5: Navigating to the Export Options Menu

From the menu in Figure 6, you can tailor your exports to various software packages:

Figure 6: The Export Options Menu

For example, if uploading GeoTIFFs to Drone Deploy, select the Drone Deploy option. This coverts the images to reflectance data, and trims the images to valid content only. The trim option removes image content that is not shared between all four of the 2p and 3p's narrowband sensors in a given scene.


To export processed images formatted for Pix4D, select the Pix4D option. This converts the images to reflectance data and does not trim to valid content.


Various softwares such as ArcGIS and Drone Deploy require different image settings for proper background transparency. Select the appropriate setting, Extra Plane or Extra Sample, depending on where you intend to export your maps (for GeoTIFFs and Shapefiles only). These settings are only allowed when exporting map layers Separately, rather than as Multipage TIFFs.


An example of a Stress map GeoTIFF uploaded to Drone Deploy with the correct transparency setting: Extra Sample


An example of a Stress map GeoTIFF uploaded to Drone Deploy with the incorrect transparency setting: Extra Plane


results matching ""

    No results matching ""